Compatibility & Requirements for Magic Earth

iOS


Requires iOS 12.0 and watchOS 5.0 or later. Compatible with iPhone, iPad, and iPod touch.


Android


Compatible with Android 4.1 (Jelly Bean) or better.

If you have any suggestions, questions or need help, you can contact us at support@magicearth.com